Resolved
Some services might currently be down due to ongoing Cloudflare issues

Started
June 21, 2022 at 7:19 AM
Status
Resolved after less than a minute
Affected
rpc.flashbots.net

Impact

Major outage